Tip #376: Stay with the versions

Andre “I’ve got 88 in my handle” Margono reports from the development trenches:

Based on the recommended practice to get the latest assemblies of Dynamics CRM SDK through Nuget I encountered one problem when I recently working on a demo with a CRM online instance.

Tipp Jarr: the problem Andre has encountered is that when you have a good old project and pull the latest CRM assemblies via Nuget
Latest CRM Assemblies on Nuget
then chances are you will receive the following (misleading) errors when building the project:

The type or namespace name ‘Xrm’ does not exist in the namespace ‘Microsoft’ (are you missing an assembly reference?)

What it means is that your project is compiled using Target framework 4.5.1 or earlier while latest CRM SDK wants at least 4.5.2.

As Andre continues:

As I’m still using Visual Studio 2012 (due to limitation of Developer Toolkit that currently supports up to VS 2012), I haven’t installed .Net framework 4.5.2 that required by the latest SDK v.7.0.0.1. Once I applied the .Net 4.5.2 update (developer pack version – t.j.), I get back with the development activities.

Tipp Jarr’s double-dip

And this is the perfect opportunity to observe chocolatey in action while you’re having a cup of beverage of your choice. Repeat after me: clist netfx-4.5.2-devpack.

Tweet about this on TwitterShare on Facebook0Share on Google+0

Leave a Reply

Your email address will not be published. Required fields are marked *